Jump to content
Get SynergyOpen a support ticket

1.7.3 - Super High CPU usage. (Windows 64bit)


Recommended Posts

Server cpu usage was at - 20%-30% at idle. Client cpu usage was at 40-49% at idle... macosx 10.10 - 1.7.3 seemed fine. Had to downgrade to 1.7.2 stable and it went back to normal... I hope... Both are windows 10 latest tech build I will not be downloading updates until this is fixed I don't know if this is just me/my config but very odd. I did not find out until I heard the fans on my PC.
Link to post
Share on other sites
Jared Schumacher
Same here. Server: Windows 8.1 64-bit 30% CPU for synergyd process Client: Linux Mint 17.1 64-bit 1% SSL works though! I tested with SSL on and off and switching client and server modes. The issue only arises on Windows in server mode as it appears to be a Synergy service issue only.
Link to post
Share on other sites
Aaron Herzon
Similar issue here. Server is W7-64. No issue here. Client is W10-32, usage goes to about 50% after some time. I can get it to go back down with some fiddling. SSL does not work and is turned off on both sides. Both installations have been activated with a paid account. UPDATE: Seems like rolling just the client back to 1.7.2 resolved the issue. Server is still running 1.7.3 UPDATE #2: Server started showing high CPU usage (25%, quad-core). I rolled the server back t0 1.7.2 to see if this would help. I also noticed that the CPU goes down when the GUI is opened. This is noted later in this thread. Edited by Guest
Link to post
Share on other sites
Ad van Steenbruggen
Have the same problem, synergyd taking up to 30% server w64 client w64 client mac osx i found out that if you open the gui (synergy.exe) the cpu will go back to normal. hope they fix this soon.
Link to post
Share on other sites
Jackson Dunstan
[quote="Ad van Steenbruggen"]Have the same problem, synergyd taking up to 30% server w64 client w64 client mac osx i found out that if you open the gui (synergy.exe) the cpu will go back to normal. hope they fix this soon.[/quote] I can confirm this. I have the same setup, except only the Mac client. CPU drops from ~13% to 0-2% after opening then closing the GUI.
Link to post
Share on other sites
Rogelio Garza
Same issue here, I have a Windows 8.1 64bit Server with a i7-3770K. synergyd.exe showing around 15% CPU usage. opening the GUI does return it back down to normal.
Link to post
Share on other sites
Quinn Osha
Almost identical issue here. Synergy pro 1.7.3 Windows 7 (64 bit) Client @25% cpu Mac OSX Server @ ~0% cpu Opening the GUI sends win7 back to ~0%.
Link to post
Share on other sites
marius banica
Hi confirmed same issue here as well, client win7 server 10.1 connectivity wifi ver 1.7.3 25% cpu on idle constant, open the gui , close the gui goes back to normal. the synergy is started in both as service. thanks
Link to post
Share on other sites
Jimmie Lightner
Same here. Windows 8.1 Enterprise and Windows 10 10074 both exhibit ~20-30% cpu usage by Synergy at idle.
Link to post
Share on other sites
I am seeing the same, but only on my server side. Server OS = Win 10, 64bit Tech preview Build 10074 CPU = AMD Athlon 64 X2 4400+ 2.3GHz, 4GB RAM Synergy Pro 1.7.3 - Registered to me, SSH on When Synergy is running as a process - uses 40-50% CPU When I open GUI, drops to ~1% *** HERE'S A DIFFERENCE *** Client OS = Win 7, 64bit SP1 CPU = Intel Core i5 M540 2.53GHz, 8GB RAM Synergy Pro 1.7.3 - Registered to me, SSH on CPU is always ~1%, GUI or not
Link to post
Share on other sites
Temporary "solution". Not close the GUI with the X... just click en Help---->Hide In both, client and server side. If you close with the X, the process eat alot CPU. bye!
Link to post
Share on other sites
Andy Hall
I have been having the same the same problem since I installed 1.7.3 earlier this week. Windows 7 Pro 64-bit for both client and server. In the last incident, I was using Excel on the server side, tried to open a 3rd Excel spreadsheet, and accidentally hit some strange key sequence along the way. The Excel screen froze and synergyd.exe and EXCEL both went to 50% CPU utilization. I stopped Synergy, X'ed out of all Excel windows, restarted Synergry and got back to normal. If a nightly build has fixed it, is it sufficient to download the .msi and try it?
Link to post
Share on other sites
david kuhl
[quote="D-VO"]The latest nightly build fixed this issue. synergy-project.org/nightly[/quote] I too was having high CPU issue and the latest nightly build fixed it, thank you!
Link to post
Share on other sites
Jeffrey Pratt
I am also having the same problem. I notices my fan was on high, the battery was taking a long time to charge and the system was getting very hot. I was running Excel and checked task manager, Synergy showed 53% CPU utilization. I closed all open programs to reboot and Synergy was 30 to 33% CPU utilization. When not plugged in it is draining my battery very fast. Synergy 1.7.3 Running as client, server is not connected Windows 8.1 Pro 64-bit i7-4650U CPU @ 1.70GHz 2.3GHz
Link to post
Share on other sites
  • 3 weeks later...
MJ Mombourquette
I had the same problem. the CPU usage was normal while the client window was open but shot up within seconds of closing it and would drop back to normal within seconds of opening it again. I'm using a Surface 3 Pro running Win 8.1 with an I7 processor. When I downgraded to 1.7.2, everything went back to normal.
Link to post
Share on other sites
cody siegel
[quote="David Tepper"]Same problem - hiding the UI by going to Window -> Hide fixes the problem[/quote] Thank you. This was driving me nuts trying to figure it out.
Link to post
Share on other sites
Jeffrey McAnarney
I have the same issue, and since I start Synergy as a service, I am not sure the hiding the GUI hack will alleviate it. I will install the nightly build and see if that fixes it
Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...