Jump to content

Hello! ūüĎč

These forums are now archived (read only).

Join us on Discord.

Synergy keeps on auto-restarting ("detected process not running, auto restarting)


Recommended Posts

jellybeans

 

Devices:
- Server hosted on Late 2013 retina Macbook Pro on Mac OS Sierra (version 10.12) running Synergy version 1.8.8-stable-25a8cb2
- Client is a Surface Pro 4 running on Windows 10 (version 1703, OS Build 15063.483) running Synergy version 1.8.8

Error log:

[2017-07-26T21:57:30] ERROR: process exited with error code: 4
[2017-07-26T21:57:30] INFO: detected process not running, auto restarting
[2017-07-26T21:57:31] INFO: starting server
[2017-07-26T21:57:31] INFO: config file: /var/folders/ct/66lyjky92mncf983dpcvcp2h0000gn/T/Synergy.xr0586
[2017-07-26T21:57:31] INFO: log level: INFO
[2017-07-26T21:57:31] INFO: log file: "/var/log/synergy.log"
[2017-07-26T21:57:31] ERROR: cannot read configuration "/var/folders/ct/66lyjky92mncf983dpcvcp2h0000gn/T/Synergy.wr0586": read error: line 9: invalid screen name "John - Surface Pro 4"
synergys: no configuration available

Link to post
Share on other sites
Paul Suarez

Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

  • Like 1
Link to post
Share on other sites
jellybeans
  • Surface Pro 4
    • Client
    • Windows 10 Pro, 64 bit,¬†Version 1703, OS Build 15063.483
    • Synergy Version 1.8.8-stable-25a8cb2
    • Connected via Wi-Fi
  • Late 2013 13in. Macbook Pro Retina
    • Server
    • MacOS Sierra¬†10.12, 64 bit
    • Synergy Version¬†1.8.8-stable-25a8cb2
    • Connected via Wi-Fi

I have tried uninstalling & re-installing Synergy on both machines, but that did not work on either machine.

Macbook Synergy UI.png

Macbook Server Config UI.png

Surface Pro 4 Synergy UI.PNG

Edited by jellybeans
Link to post
Share on other sites
  • 2 weeks later...
jellybeans

Hi Paul,

I tried uninstalled the latest version of Synergy from both my devices & installed the Synergy 1.9-rc3 version on both devices. This did not fix anything unfortunately.

  • Surface Pro 4
    • Client
    • Windows 10 Pro, 64 bit,¬†Version 1703, OS Build 15063.483
    • Synergy Version 1.9.0rc3
    • Connected via Wi-Fi
  • Late 2013 13in. Macbook Pro Retina
    • Server
    • MacOS Sierra¬†10.12, 64 bit
    • Synergy Version¬†1.9.0rc3
    • Connected via Wi-Fi

 

 

 

MacOS Server Config.png

Surface Pro 4 Client.PNG

MacOS UI.png

Link to post
Share on other sites
  • 2 years later...

Having the same problem with newly installed version 10.10.3 running on macbook pro macOS Mohave 10.14.6

I uninstalled and reinstalled the application and still same issue. 

P.S.: tyrion-21 is hostname

2019-09-04T09:38:07] DEBUG: starting process
[2019-09-04T09:38:07] INFO: starting server
[2019-09-04T09:38:07] INFO: config file: /var/folders/0b/vrgq4sd131vb3kwkd5ll8xsh0000gn/T/Synergy.EJ1427
[2019-09-04T09:38:07] INFO: log level: DEBUG2
[2019-09-04T09:38:07] INFO: drag and drop enabled
[2019-09-04T09:38:07] DEBUG: opening configuration "/var/folders/0b/vrgq4sd131vb3kwkd5ll8xsh0000gn/T/Synergy.tT1427"
[2019-09-04T09:38:07] FATAL: unknown screen name `tyrion-21.local'
[2019-09-04T09:38:07] DEBUG: configuration read successfully
[2019-09-04T09:38:07] DEBUG1: thread 0x00000002 entry
[2019-09-04T09:38:07] DEBUG1: caught cancel on thread 0x00000002
[2019-09-04T09:38:07] ERROR: process exited with error code: 1
[2019-09-04T09:38:07] INFO: detected process not running, auto restarting
[2019-09-04T09:38:07] DEBUG: stopping process
[2019-09-04T09:38:07] INFO: stopping synergy desktop process

 

Link to post
Share on other sites
  • 2 years later...
Synergy User Mac M1

Having the same issue, using Mac OS 12.0.1(Mac Mini) and Mac OS 11.3.1 (MacBook Pro)

[2022-01-13T11:03:57] INFO: process exited normally

[2022-01-13T11:03:57] INFO: detected process not running, auto restarting

[2022-01-13T11:03:58] INFO: starting server

[2022-01-13T11:03:58] INFO: config file: /private/var/folders/5g/c6rvpsr962q2w270k541r40m0000gn/T/Synergy.zrNVBv

[2022-01-13T11:03:58] INFO: log level: INFO

[2022-01-13T11:03:58] NOTE: started server, waiting for clients

 

Only way too reconnect after that (at least that's how I do it), is to go disconnect client from network...reconnect and then restart synergy server.

Please suggest a solution to this, very frustrating to do this again n again

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...