Jump to content

Hello! ūüĎč

These forums are now archived (read only).

Join us on Discord.

Fwd & Back Mouse buttons


Craig Emery

Recommended Posts

Perhaps the holiday season has reduced Symless head-count temporarily.

But this thread has ground to a halt.

Link to comment
Share on other sites

  • 1 year later...

@Alexey Pilyaev I am having the same troubles. Using a logitech mouse, all special buttons do not work (fw/bw, zoom and switch applications button).

Currently running the newest version available (v2.0.12 (beta))

Link to comment
Share on other sites

Some users have installed Synergy 2 Beta without knowing that it's now a beta version. It's still at the early prototyping stage and contains many bugs. You may not be aware that Synergy 1 is actually the current stable version. So if this is the case, please could you switch to Synergy 1? Make sure you uninstall Synergy 2 Beta.

See this guide for more details:
https://symless.com/help/s2-troubleshooting/s2-beta-inf

Link to comment
Share on other sites

11 minutes ago, Alexey Pilyaev said:

Some users have installed Synergy 2 Beta without knowing that it's now a beta version. It's still at the early prototyping stage and contains many bugs. You may not be aware that Synergy 1 is actually the current stable version. So if this is the case, please could you switch to Synergy 1? Make sure you uninstall Synergy 2 Beta.

See this guide for more details:
https://symless.com/help/s2-troubleshooting/s2-beta-inf

I already switched, thanks :-)

Link to comment
Share on other sites

2 minutes ago, Alexey Pilyaev said:

Please let me know is it working for you.

Yes, and I've got a Logitech MX Ergo now, and that seems to work fine too.

Except that the left & right "lean on the scroll wheel" clicks aren't working. Not a massive deal. But worth mentioning.

Link to comment
Share on other sites

  • 2 years later...

Hi

I'm new to this forum.  I've been running Synergy for a while and have always had the Back and Forward buttons not work, but I've never sought a solution for it till now.  I am running 1.14.0-stable on Windows as server and Ubuntu as client.  My problem is I don't know how to start Synergy with a configuration file.  The Autostart is in /usr/share/applications and my config with the additions is in /home/ian/.synergy/MySynergy.conf.

Re-starting Synergy from a command line as follows does not work.  It doesn't seem to pickup the conf file.

/usr/bin/synergy --config '/home/ian/.synergy/MySynergy.conf'

Result: QSystemTrayIcon::setVisible: No Icon set
("-f", "--no-tray", "--debug", "INFO", "--name", "192.168.0.xx", "--enable-crypto", "--tls-cert", "/home/ian/.synergy/SSL/Synergy.pem", "192.168.0.xx:24800")

It seems the "--config" is wrong.  I've had numerous mice, and numerous Windows machines and numerous installs of Ubuntu over the years with the same problem.  The mouse scrolling wasn't working till last week when I stumbled on the answer.  So I'm encouraged to seek a solution for the back and fwd buttons on my mouse.  Hope someone here can help.

Thanks

Ian

Link to comment
Share on other sites

I figured out my error.  I was trying to configure the client, when the configuration applied to the server only.  So I turned my attention to the server (Windows) and entered the two lines in the configuration file from the UI, and that fixed it.  I now have a fully functioning mouse in my Ubuntu client ... for the first time.

Thanks to all for the postings that provided clues.

 

Link to comment
Share on other sites

  • 1 year later...

Still exists in 2023 with v1.14.6 and MacOS 12.6.3 (server and client) - the solution for me was to uninstall the Logitech Options app from the server machine. The fwd/back buttons still work as expected but now also work on the client as well. With the Logitech Options app installed on the server it was hit or miss if the button presses would be logged or not. Seems like they were being logged (during boot up) until the Logitech app started, then nothing was logged for these buttons, even though they were still working .

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...