Jump to content

Error:no configuration available


wls1990

Recommended Posts

PC running win10 as server.

Mac as client.

 

PC’s log:

synergys.exe: no configuration available

[2017-06-21T14:05:30] ERROR: failed to launch, error: process immediately stopped

[2017-06-21T14:05:30] INFO: backing off, wait=10s, failures=31

[2017-06-21T14:05:40] INFO: starting new process

[2017-06-21T14:05:40] INFO: starting new process

[2017-06-21T14:05:40] INFO: activeDesktop:Default

[2017-06-21T14:05:40] INFO: drag and drop enabled

synergys.exe: no configuration available

[2017-06-21T14:05:41] ERROR: failed to launch, error: process immediately stopped

[2017-06-21T14:05:41] INFO: backing off, wait=10s, failures=32

[2017-06-21T14:05:51] INFO: starting new process

[2017-06-21T14:05:51] INFO: starting new process

[2017-06-21T14:05:51] INFO: activeDesktop:Default

[2017-06-21T14:05:51] INFO: drag and drop enabled

 

And over and over again...

Link to comment
Share on other sites

Paul Suarez

Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Link to comment
Share on other sites

server: Windows PC
syetem: 
win 10 1607 ,64bit, 
OS:14393.1358

Synergy version:
1.8.8-stable-25a8cb2

Network: 
server:Ethernet
client:Wi-Fiserver.thumb.png.80d0aac4f5703a824d61e1b02e3472fb.png

2017-06-26_160116.png

2017-06-26_160104.png

屏幕快照 2017-06-26 下午4.00.14.png

Link to comment
Share on other sites

Paul Suarez

Can you try editing the Mac's screen name? Try removing the ".local" on it. Make sure to edit the server configuration on your server for it to reflect the change of screen name on your Mac.

Link to comment
Share on other sites

Paul,

This is the exact same issue happened to me after Synergy had been working for months. I tracked it down to the fact that one of my remote PCs had the LAN IP address change. Once I pointed the server to the new IP,  everything started working again. 

SGJ

Link to comment
Share on other sites

  • 11 months later...
liquidcable

I had this same issue. I had to uncheck the "Server (share this computer's mouse and keyboard), then uncheck it. After that it starting working again. This is a bug.

Link to comment
Share on other sites

  • 5 months later...
StefanMuirhead

Liquid Cable: Thanks, that fixed it for me, unchecking server and relaunching did the trick. 

Was starting to get frustrated and appreciate your help!

Link to comment
Share on other sites

  • 4 months later...
  • 2 months later...
  • 7 months later...

This kind of seems like a bug that is still happening.  I've had it happen lots of times before and I believe clicking the "Configure server" button and then "OK" would fix it.

I just had it happen now, Googled, found this thread, and did the uncheck/recheck server fix and it worked, and I'm noticing this:

image.thumb.png.52a5ada6102aeda968d5f4e1abb3ce19.png

After unchecking and re-checking the server checkbox, the config file it finds is in a temp directory.  Is it possible that windows is cleaning up this file, and the uncheck/re-check re-creates it?

The server is Windows 10.  The client is a Macbook

  • Like 1
Link to comment
Share on other sites

  • 1 month later...
joshuagilbreath

I had the same issue, unchecking and rechecking the Server (share this computer's mouse and keyboard) check box fixed the issue.

Link to comment
Share on other sites

  • 1 month later...
CodySydney

Smart thinking!  I just had the same problem.   Ver 1.11.1, had also been working fine for a while (fine = since the 2000's haha) and like you I see this:

[2020-06-10T09:21:13] INFO: config file: C:/Users/micro/AppData/Local/Temp/Synergy.aVhZZy

I just did a Windows update before this issue so if there is ever going to be a time Windows does a Temp cleanup I reckon that's it.  I think your theory seems pretty solid.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...