Jump to content

Drag and drop files


Recommended Posts

Here are a few general notes about File Drag and Drop. In the old days, you had to be logged in to Synergy Premium in order to enabled Drag and Drop. In 1.6.2 and newer, we removed this requirement and now Drag and Drop is enabled by default. You should get a log message that "Drag and Drop is enabled" or similar. If you have that message, you should be able to drag a file's icon right off the edge of the screen, and it should appear on the desktop of the other computer a few seconds later. I heard from a few users who stated that rebooting got file drag & drop to start working. Try a simple test to help narrow down where the problem is. A plain text file named something like "test.txt" and containing only a few letters. If that works, then work your way up from there until you find something that doesn't work. If you go through this process, please report to us what does and doesn't work so we can work on it. Drag and Drop is still a fairly new feature. Some bugs are being worked out. If the above still doesn't work, please increase your logging level to Debug2 and then send us some log output from the moment you try to drag a file across screens. Some final notes: File Drag & Drop is only currently available on Windows (Vista and newer) and Mac (OSX 10.7 and newer). Also, only single files are supported: no folders, no groups of files. And, if your file's icon travels over another icon or window on the way to the edge of the screen, this can break the drag & drop feature.
Link to comment
Share on other sites

  • 7 months later...
  • 9 months later...
  • 2 weeks later...
Theodoros Kondakos

I have similar problems. My setup is a dual screen Windows 10 Pro and a laptop Windows 10 Pro both fully updated.


I tried to copy the "test.txt" file with just some bytes of info and the first time it worked. Then i tried to copy a 323kb jpg. It didn't worked, then i tried to copy a 14kb txt file, didn't worked again. Finaly i deleted the test.txt and tried to drag and drop again, but this time even this didn't worked.


I attach the synergy.log file https://drive.google.com/open?id=0B2PyZ ... mVTdTlQNDg

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...