Jump to content

Mouse cursor is not hidden on client when leaves the screen


seun

Recommended Posts

Dear team Synergy. Thank you so much for the great software. I have a question about a mouse pointer issue on my client machine (windows10 laptop).

 

When using Synergy on my laptop, if my mouse leaves the screen, the cursor jumps to the middle. The cursor obscures the middle of the screen. There is no program interferes with the mouse cursor and it doesn't have attached mouse.

 

I'm using my own configuration on my host machine (ubuntu12.04, workstation). Please check if I have anything wrong in the conf. My Synergy version is 1.8.8 on both machines. Thank you so much for your help.

 

 

section: screens
    seun-laptop:
        halfDuplexCapsLock = false
        halfDuplexNumLock = false
        halfDuplexScrollLock = false
        xtestIsXineramaUnaware = false
        switchCorners = none 
        switchCornerSize = 0
    ace-ws-30:
        halfDuplexCapsLock = false
        halfDuplexNumLock = false
        halfDuplexScrollLock = false
        xtestIsXineramaUnaware = false
        switchCorners = none 
        switchCornerSize = 0
end

section: aliases
    seun-laptop:
        %MY_IP_ADDRESS%
    ace-ws-30:
        %MY_IP_ADDRESS%
end

section: links
    seun-laptop:
        right = ace-ws-30
    ace-ws-30:
        left = seun-laptop
end

section: options
    heartbeat = 5000
    mousebutton(6) = keystroke(WWWBack)
    relativeMouseMoves = false
    win32KeepForeground = false
    clipboardSharing = true
    switchCorners = none 
    switchCornerSize = 0
end

Edited by seun
Link to comment
Share on other sites

Hi Paul, Thank you for your comment. I changed it to 'true' and restarted Synergy on both machines but it is the same.

Link to comment
Share on other sites

Paul Suarez

Thanks for verifying that @seun. I'll need to check this with our developers, however they are out of the office already. We hope it'll be fine with you if we reply tomorrow when they're around.

Link to comment
Share on other sites

  • 4 weeks later...

Hi Paul,

Could you maybe give me the follow-up that you checked with the developers, please ?

Thank you very much!

 

Link to comment
Share on other sites

Paul Suarez

Hi @seun. Can you check Settings> Devices> Mouse & Touchpad> Additional mouse options>  Pointer Options on your Windows machines. Check if "Hide pointer while typing" has a check mark.

Link to comment
Share on other sites

Hi Paul,

I sincerely appreciate the follow-up. I tried to turn on / off the "Hide pointer while typing" option, but unfortunately, it had no effect on the cursor issue.

One more thing I noticed was that the mouse cursor hid from the Windows machine exactly 10 minutes later. This is very interesting.

Thank you so much.

Link to comment
Share on other sites

Paul Suarez

Can you try setting Synergy's elevation level on your Windows machine to "Always?"

  1. Click Edit
  2. Click Settings
  3. Set Elevate to Always
  4. Click OK
  5. Click Apply
  6. Click Stop
  7. Close Synergy
  8. Re-launch Synergy
  9. Click Start

Also, just wanted to make sure about one thing. Have you left the "Hide pointer while typing" option switched on or off?

Link to comment
Share on other sites

  • 4 weeks later...

Hi Paul,

I recently changed my switching hub and it solved the problem. I don't really understand why...???

Anyway, thank you so much for your follow-ups and I hope you have a great week !!

Link to comment
Share on other sites

Paul Suarez

Hey @seun. Thanks for the update on this. Can you confirm though if what you have used before is a hub or a switch? Also, are you using a hub now or a switch?

Link to comment
Share on other sites

Hi, I was using two wall-mounted ethernet ports for the two machines. I don't know the exact configuration of the network.

Now I have only one port connected to a switch and the switch is also connected the two machines.

 

Simply like this:

Internet

    |

switch

|       |

A     B

 

So basically the two machines are now communicating via the switch, not through the network in my office.

 

Thanks !

Link to comment
Share on other sites

Oh god... It came back again. Maybe the fix by switch was just a coincidence. But never mind. I'm getting used to it. Anyway, thanks a lot for your help.

Link to comment
Share on other sites

  • 1 month later...
On 8/3/2017 at 8:18 PM, seun said:

Oh god... It came back again. Maybe the fix by switch was just a coincidence. But never mind. I'm getting used to it. Anyway, thanks a lot for your help.

I've been having the same issue, infact Support referred me here.

 

I've found that if you open Synergy (on the client) then hit Window > Hide - the mouse then disappears on the client and it works as it should, at least until you reboot the system then you need to do it again.

You can also hit the Minimize button but this leaves the client open in the taskbar which isn't ideal.

(If you open the client then hit the X - the problem remains)

Link to comment
Share on other sites

Hi Blank3k,

I do appreciate your note. It's very funny that I never tried the Window > Hide method. I always clicked X to close it. I feel much better with the Synergy now : ))

Thank Nick and Paul very much as well !!

Seun

Edited by seun
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...