Jump to content

Hello! ūüĎč

These forums are now archived (read only).

Join us on Discord.

Wrong keycodes on certain keypresses

Recommended Posts

Though I'm not really sure why I can't post in the General forum but ok...

I still have issues, because on my client PC does not recognise certain keypresses... for example ctrl+f and ctrl+v (which I use mostly)...

I have tested the keypresses and both buttons separately work ok:

V = 118

C = 67

Ctrl = 17

Ctrl + V = 50 (<-- which is actually "2", so I'm not sure why this is recognised as a separate keypress)

Ctrl + F = 219 (<-- also no idea what this is)

Ctrl + C = 17 & 67 (<-- this one seems to work fine)

Link to post
Share on other sites
Paul Suarez

Hi @Borut. Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server).

Link to post
Share on other sites

Server: Windows 10 -- 1.8.8-stable-25a8cb2
Client: Ubuntu 16.04 -- 1.8.8-stable-25a8cb2
Both 64bit, ethernet

Link to post
Share on other sites

Win: sl, eng
Ubuntu: si, us
Both default layouts are slovenian. The strange thing is, that sometimes the copy/paste/find shortcuts work... I don't do anything special, it just switches to work... no idea when and why.

Link to post
Share on other sites

No, nothing changes. Still the same issue... also what I think is also a keycode issue (which I already posted a few weeks ago) -- the front/back keys on my mouse (Logitech G402) are recognised as left/right (like some mouses have on their scroll wheel, where you can move them left/right; but this one doesn't)... but that never really worked. Copy/paste at least at some times works fine ...

Link to post
Share on other sites
Paul Suarez

Please set both machine's logging level to Debug 1.

*Before starting with the steps, make sure that both machine's Synergy is not running (stopped)

  1. Click Edit (on top)
  2. Click Settings
  3. Set Logging level to Debug1
  4. Click OK
  5. Restart Synergy by closing and re-opening it

* Do the same steps on both machines before trying to reconnect

Paste the log results on Pastebin or Gist then post the link here.

Make sure to pay attention on what it generates when you try to press each button on your mouse. You can provide us a list of it.

For example:

left click:
right click: 
middle click: 

Also, please confirm if you have Logitech Gaming Software installed and what firmware version do you have for your G402 mouse.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...