Jump to content
Get SynergyOpen a support ticket


Recommended Posts

  • 1 month later...
Erwin S.

Don't get the sense that it's high on the priority list. Hopefully, more people will chime in and will get some momentum.

Link to post
Share on other sites
  • 3 months later...

For this to work you probably need to use ChromeBrew and/or LinuxBrew to get the required packages in order to build Synergy from Source. This will require your Chromebook/Chromebox to be in Developer mode and a little bit of work setting up the aforementioned software systems. I'm actually looking to do the same since I use Synergy at work on a daily basis and would love to be able to use my personal Chrome device for personal business alongside my work machines.

Link to post
Share on other sites
  • 2 weeks later...
  • 4 months later...

@dragon788 I tried your strategy.  Here are some notes:

- The synergy code needs curl.h, chromebrew will fetch you the curl binaries but not the headers

  - You can get curl source here https://curl.haxx.se/download.html, after running `cmake` I had to make this modification: https://stackoverflow.com/questions/42666288/curl-cross-compiling not sure if your chromebook will be the same

- The synergy code also needs Xlib.h, which comes with chromebew package libx11

- The synergy code also needs Xtst, which doesn't appear to be in chromebrew.  It's code lives here: http://t2sde.org/packages/libxtst.html but `/bin/sh configure` says "configure: error: cannot run C compiled programs.  If you meant to cross compile use --host."


I'm still churning on this last one, but if I overcome it, I'll be sure to report back here.


Link to post
Share on other sites

You could look at the package compile options on Gentoo or Arch to see if you can find the right set of flags since Chrome OS is built on a Linux kernel and uses emerge and portage of Gentoo origin.

Link to post
Share on other sites

Thanks for the tip.  It turned out being something else--I hadn't disabled `noexec` in the local filesystem, which caused the configure script to fail and give a misleading message.  Fixed by: `sudo mount -i -o remount,exec /home/chronos/user`

I wound up fulfilling the dependency tree, which included building quite a few packages:

curl fixesproto libxi recordproto synergy-core xext xfixes xtst

Unfortunately, once I had synergy built on my chromebook, I ran the integration tests and most of them failed:

[  PASSED  ] 5 tests.
[  FAILED  ] 12 tests, listed below:
[  FAILED  ] ArchInternetTests.get
[  FAILED  ] XWindowsKeyStateTests.setActiveGroup_pollAndSet_groupIsZero
[  FAILED  ] XWindowsKeyStateTests.setActiveGroup_poll_groupIsNotSet
[  FAILED  ] XWindowsKeyStateTests.setActiveGroup_customGroup_groupWasSet
[  FAILED  ] XWindowsKeyStateTests.mapModifiersFromX_zeroState_zeroMask
[  FAILED  ] XWindowsKeyStateTests.mapModifiersToX_zeroMask_resultIsTrue
[  FAILED  ] XWindowsKeyStateTests.fakeCtrlAltDel_default_returnsFalse
[  FAILED  ] XWindowsKeyStateTests.pollActiveModifiers_defaultState_returnsZero
[  FAILED  ] XWindowsKeyStateTests.pollActiveGroup_defaultState_returnsZero
[  FAILED  ] XWindowsKeyStateTests.pollActiveGroup_positiveGroup_returnsGroup
[  FAILED  ] XWindowsKeyStateTests.pollActiveGroup_xkb_areEqual
[  FAILED  ] CXWindowsScreenTests.fakeMouseMove_nonPrimary_getCursorPosValuesCorrect

I was hoping that hunting down the dependencies and getting it built in chrome would put a dent in this, but I'm getting the feeling that having it work well here will require a bit more integration work than that.

Link to post
Share on other sites

Yeah, the problem will be that Chrome OS has moved away from Xorg and is using a UI layer called Freon which has Wayland roots and I'm not sure Synergy supports that yet.

Link to post
Share on other sites
  • 1 year later...
  • 4 months later...

Sadly ChromeOS uses Wayland and not Xorg, so even if you install it you'd probably only be able to partially interact with one app, and possibly not even that because ChromeOS uses a tool called sommelier to let Xorg apps launch into Wayland.

Link to post
Share on other sites
Kelvin Tran

I'll lock the topic now.

Final verdict: until announced later on down the line, Android/ChromeOS will not be officially supported releases.

If you need ChromeOS, you can try Linux emulation. Be warned, however, that will take work.

Edited by Kelvin Tran
Link to post
Share on other sites
  • Kelvin Tran locked this topic
This topic is now closed to further replies.
  • Create New...