Jump to content
Get SynergyOpen a support ticket

Keyboard layout switches between machines


Johannes Frank

Recommended Posts

Johannes Frank

Setup:

2x Xubuntu 16.10 Boxes.

Language: English,

Keyboard layout: de_DE,

Synergy Version: 1.8.7-stable-9799e96

 

When typing with the local keyboard on both machines, I have german layout as expected. However, if I type on the client machine via Synergy, the layout switches to en_US (y->z etc.) at the same time, typing locally on that client machine reveals that the actual local layout is still de_DE so there appears to be some kind of mapping that is not properly done on synergy's side (I didn't find any correlating configuration entry, which is why I'm posting here).

 

 

On a side note: Wasn't priority support originally part of the $29 package? I'm pretty certain it was the reason for me to pay $29 instead of $19, however looking at the current pricing table it is now only for enterprise quota?

 

Edit: Ok I am sick and therefore forgot to actually ask the question xD How do I fix this? Is this a system configuration error, a synergy configuration error or a bug?

Link to post
Share on other sites

We're aware of this issue and we're working to get a fix out.

 

It is rooted deep within the program though so it'll be a while before we have anything concrete to solve it for you. For now, the best workaround is to use a US or UK QWERTY keyboard as these work perfectly within Synergy.

Link to post
Share on other sites
Johannes Frank
We're aware of this issue and we're working to get a fix out.

 

It is rooted deep within the program though so it'll be a while before we have anything concrete to solve it for you. For now, the best workaround is to use a US or UK QWERTY keyboard as these work perfectly within Synergy.

 

Is there any workaround in the meantime? Qwerty is not an option, since as I'm german I'm dependant on the special characters äöüß quite frequently (which are not present on an US/UK Keyboard)

 

Kind Regards

Link to post
Share on other sites
Peter Holtwick

I have the same problem. But I noticed that, when I show the keyboard layout in the system tray (DE/EN), it was changed to EN when the issue occured. Simply moving the mouse back to the server screen was switching back to DE.

Link to post
Share on other sites
Johannes Frank
I have the same problem. But I noticed that, when I show the keyboard layout in the system tray (DE/EN), it was changed to EN when the issue occured. Simply moving the mouse back to the server screen was switching back to DE.

 

hmm I'll have to verify that. However, it doesn't really make a difference because "simply using qwerty" is just not feasible. Having to escape/circumvent every instance of äöü is just plain impossible in a german environment.

Link to post
Share on other sites
  • 5 years later...
sasklacz

Have you thought about fixing this ? It's 2022 I have a Dvorak keyboard and randomly my layout will switch to Qwerty or something even different on both the server and the other machine. Windows 10/OSX 10.14

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...