Jump to content

Hello! 👋

These forums are now archived (read only).

Join us on Discord.

1.8.3 failed to connect to server

Roberto Paolinelli

Recommended Posts

Darin Hamilton

Received these instructions by email from the Synergy team. They resolved the issue for me.


There's a known issue in Synergy 1.8.3 where the SSL plugin can be out of date, which stops the client connecting to the server. To fix this, please re-run the wizard on all of your machines.


1. Open Synergy on the server

2. If Windows: Go to the Edit, then click Settings

3. If macOS: Go to Synergy, then click Preferences

4. Ensure the "Use SSL encryption" checkbox is enabled

5. Go to File, then Run Wizard

6. Click Next until you see the Activation screen

7. Enter your login details or serial key

8. Click "Continue" and finish the wizard

9. Repeat those steps for each client


I'm sorry you had to do that, it's a pretty major screw up on our part, sadly we didn't see this while testing. If those steps don't help, please let us know so we can troubleshoot further. Thanks for your patience!


This worked for me too.


A re-gen cert button next to the enable SSL flag would be helpful here.

Link to post
Share on other sites

Sadly all those steps didn't work for me. I tried everything. Running the wizard with and without SSL on both Server and Client. Deleting %LocalAppdata%/Synergy/*


I reinstalled multiple times, with stopping running services and so on. Restarted both machines – still no connection. The connection problems started with the update to 1.8.3. Anybody experiencing similar problems?

Link to post
Share on other sites
Hilario Ortigosa Monteoliv

Doesn't work.


I've done those steps (running wizard with SSL enabled, first on server, later on client, several times) with no success. The error message now is differnet: first talks about 'server fingerprint' on client, 'accepted secure socket' on server, and after some seconds client failed with 'Timed out' and begin again.


Macosx server, Linux client. If I disable SSL on both, it works again, as before the 'run wizard' procedure.

Link to post
Share on other sites
John Barkwell




Same problem here.


Windows 10 server, OSX 10.11.3 client.


SSL was already off. I figured that if changing SSL cured it, it must involve the network. So, I ran Windows Netword Diagnostic. It ran for less than 5 seconds and then popped up a dialogue box with two options; one of which was a question about whether it was a problem connecting to Synergy.


Clicking that question produced, almost immediately, a statement that the issue was probably with Windows Firewall. I clicked the offer to fix the Firewall problem.


Instant gratification.


Hope that's useful to someone else. On other systems I suppose networks, firewalls and maybe security software might be places to look.



Edited by Guest
Link to post
Share on other sites

On the Windows 10 (server), I had to manually stop the synergy service, then manually delete the ns.dll plugin in %appdata%\local\synergy\plugins before running the wizard could fix the problem. Not so much on the Mac. At all.

Link to post
Share on other sites
  • 10 months later...

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...