Jump to content
Get SynergyOpen a support ticket

Compling Synergy in Windows 7


Recommended Posts

Karen, There are a number of places where the wiki is in need of updates, and this is one of them. There are a number of little things that have to be set properly for the compilation to work. You'll want to add or modify a few system variables. [b]PATH[/b] needs have entries such as: [code]C:\Program Files (x86)\CMake\bin;C:\Qt\2010.02\qt\bin;C:\Qt\2010.02\mingw\bin;C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\x86_amd64;[/code] You might also need to add or correct: [code]QMAKESPEC = C:\Qt\2010.02\qt\mkspecs\win32-g++\ QTDIR = c:\Qt\2010.02[/code] Also not listed is the need presently to build OpenSSL in the [b]...synergy/ext[/b] directory which has it's own requirements. (We're working on making this part easier, but for the time being, if you receive compilation errors you probably need to build OpenSSL.) Goto the ext directory and untar the tarball [b]"openssl-1.0.2.tar.gz"[/b]. Note: [i]The contents need to be in a directory called openssl not openssl-1.0.2.[/i] here is a good page on building openssl: [url]http://developer.covenanteyes.com/building-openssl-for-visual-studio/[/url] the major changes are the prefix directory, and make the dlls not the executable. ("nmake -f ms\[b]ntdll[/b].mak") You can also skip the install step. I hope some of this helps. We'll try to get to the building wiki once we've gotten 1.7.1 settled, but the community can always improve it to ;)
Link to post
Share on other sites
Jiahong Chen
[quote="speaker"]Karen, There are a number of places where the wiki is in need of updates, and this is one of them. There are a number of little things that have to be set properly for the compilation to work. You'll want to add or modify a few system variables. [b]PATH[/b] needs have entries such as: [code]C:\Program Files (x86)\CMake\bin;C:\Qt\2010.02\qt\bin;C:\Qt\2010.02\mingw\bin;C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\x86_amd64;[/code] You might also need to add or correct: [code]QMAKESPEC = C:\Qt\2010.02\qt\mkspecs\win32-g++\ QTDIR = c:\Qt\2010.02[/code] Also not listed is the need presently to build OpenSSL in the [b]...synergy/ext[/b] directory which has it's own requirements. (We're working on making this part easier, but for the time being, if you receive compilation errors you probably need to build OpenSSL.) Goto the ext directory and untar the tarball [b]"openssl-1.0.2.tar.gz"[/b]. Note: [i]The contents need to be in a directory called openssl not openssl-1.0.2.[/i] here is a good page on building openssl: [url]http://developer.covenanteyes.com/building-openssl-for-visual-studio/[/url] the major changes are the prefix directory, and make the dlls not the executable. ("nmake -f ms\[b]ntdll[/b].mak") You can also skip the install step. I hope some of this helps. We'll try to get to the building wiki once we've gotten 1.7.1 settled, but the community can always improve it to ;)[/quote] It seems that Apple's Bonjour SDK must be installed too.
Link to post
Share on other sites
  • 2 weeks later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...