Jump to content
Get SynergyOpen a support ticket

The specified address is not available from the local machin


Howard Jones

Recommended Posts

Howard Jones
Synergy 1.7.5 on Windows 7 - I get an error message: "FATAL: failed to start server: cannot bind address: The specified address is not available from the local machine" Thing is, I didn't specify the address. In fact, I can't see how to do that in the config file or UI. So Synergy is picking a non-existent address and then failing to bind to it! I do have quite a few network interfaces, and a few of them don't actually go anywhere (loopback or VM-related interfaces). There's nothing I could see in the manual to say what the bold address in the list means, but the one in bold is a VM-related NIC, not an actual LAN connection, in case it's relevant. I'm manually entering the (correct) IP for the server on my client, not auto-config. This all did work when I first installed Synergy, but now fails reliably, even across reboots. Any ideas? I don't understand how it can find the IP of an interface, and then say that it doesn't exist! :-)
Link to post
Share on other sites
Howard Jones
Nope, still the same thing after moving the LAN interface to the top of the list. And actually, the interface in bold (I guess this is the one advertised with autoconfig?) is still a different VMware virtual interface. I'm not using autoconfig, so that's not really an issue, but the failure to bind obviously is!
Link to post
Share on other sites
  • 10 months later...
  • 3 years later...

My problem was that although the screen was showing the correct (new DHCP) address inside settings it was still the previous IP address in the interface.

Link to post
Share on other sites
  • 5 months later...
  • 1 year later...
JackLH

In version 1.14-2, I had to go to Edit | Preferences | Network IP and update the IP to the new IP address of my network interface (recently changed) despite the correct IPs showing on the main screen. (Intuitively you'd think this would be a setting found under the "Server Configuration" button and not under "Preferences"--but I suppose it's a preference to have it work or not.)

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...